Hotsync Error 8009

Symptoms

"An application on the desktop failed to respond to a HotSync notification. Please check the desktop for details. (8009) "

Cause

You might have a similar message if you try to open the File Link portion of the HotSync application. What this seems to be connected to (among other things) is having a Registry entry which points to conduits or Palm programs on your PC which aren't working or aren't on the Palm yet. Basically, your Registry entries for the Palm and HotSync don't agree with what you actually have on your computer, on your Palm, or have gotten corrupted in some way.

Solution

WARNING! Please, please, please don't mess with your Registry if you don't have a backup of your computer, don't know what youre doing, or don't like living on the edge. You could experience tragic results if you make a mistake.

You can try editing the Registry by hand if you want (and can stand the pressure) but these instructions simply delete the corrupted Registry entries, and rebuild that section of the Registry. Here are the step-by-steps:

  1. Close HotSync on the taskbar.
  2. Close any and all windows, applications or processes running.
  3. Open Regedit (go to Start menu, "Run" and type 'regedit'
  4. Export the Registry (all, not just a branch) in case you need it as a backup
  5. Open HKEY_CURRENT_USER.
  6. Open "Software".
  7. Find the US Robotics entry and expand it.
  8. Select Pilot Desktop folder and delete it.
  9. Quit Regedit.
  10. Open Run on Start menu, enter "C:\Palm\hotsync -r" using your correct path to the HotSync.exe. Be sure to add the " -r" after it. This is what will rebuild the Registry entries. After a few moments, you should see the HotSync icon appear in the System Tray on the Taskbar.
  11. Before doing anything else, restart your machine.
Everything should be working now. The basic HotSync should work. Then you can replace, reinstall, and re-setup your other applications.


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